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1
Introduction
This topic provides step-by-step instructions on how to get started in Circuit, Planar EM, and 
System design and simulation with Ansoft Designer. As you explore the program, you will:
• Start Ansoft Designer.
• Learn terms and concepts essential to understanding Ansoft Designer’s structure and behavior.
• Explore the Ansoft Designer desktop.
• Build, analyze, and report the performance of basic designs with Ansoft Designer’s Circuit, 

Planar EM, and System simulators.
The first step is to start Ansoft Designer.

Starting Ansoft Designer
Once you have installed Ansoft Designer you can start the program from the Windows Start menu. 
To do this:
1. Click Start.
2. Select Programs.
3. Select the Ansoft Designer folder.
4. Select Ansoft Designer.
If the program fails to start, make sure you have installed the licensing option provided to you. See 
the Installation Guide for detailed information on installing the software and licenses.
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Starting Ansoft Designer
Depending on your particular window configuration, you will see the Ansoft Designer desktop 
appear as in the picture below. The windows inside your Ansoft Designer desktop may be located 
differently compared to the picture.

Opening Example Projects
Ansoft Designer ships with a collection of example projects that you can load, analyze, and 
explore. To access these files, click Open on the File menu, and then browse to 
<InstallationDirectory>/Designer/Examples, where <InstallationDirectory> is the installation 
directory you specified in Ansoft Designer Setup. The examples are grouped by simulator (Circuit, 
Planar EM, System), with an additional group (Integrated) that demonstrates Ansoft Designer’s co-
simulation capabilities.
1 - 2 Introduction 



Terms Used in Ansoft Designer
Terms Used in Ansoft Designer
It is useful to become familiar with some commonly used terms as we progress through the Getting 
Started guide.

Project
A project is a design or group of designs organized and managed in one file—the *.adsn file. 
Multiple projects can be opened in Ansoft Designer concurrently.

Design
Designs are the building blocks of projects, and can be circuits, systems, or 3D planar EM models. 
Designs consist of schematics or geometrical models, model data, analysis setup information, 
output graphs and tables, and other pieces of information that go into describing simulation of 
electrical circuits.

Component
Components are the items placed on schematics and layouts that represent low-level electrical 
elements and subcircuits. A component’s graphical representation in a schematic is a symbol, while 
in a layout it is a footprint. Components have pins for connections, bitmaps in the project tree, and 
properties for simulation. A component can be associated with more than one simulation if it can be 
analyzed in more than one simulator.

Library
Components are organized into libraries. Libraries are then configured by the user (manually) or by 
loading technology files (automatically) making them available for use in building designs. System 
libraries are provided with Ansoft Designer. User libraries and Personal libraries are used to add 
foundry support, user defined models, and any custom set of components or simulation models.

Technology File
A technology file initializes a design with a set of data to avoid repeated entry of commonly used 
data. This data can consist of layers and stackup information for layout, configured libraries of 
components, and substrate definition(s) for circuit analysis. Users and foundries can customize 
Technology files for their own manufacturing process and simulation models.

Layers and Stackup
Layers are used in the layout editor to organized and operate on sets of geometry or other visual 
indicators. Signal, metallized signal, and dielectric are common physical layers, while symbol (to 
show component symbols in layout), error, and rats (to show connectivity) are non-physical layers. 
The stackup contains additional properties of the physical layers, such as material, thickness, and 
elevation. Geometrical information on these layers is used to generate masks for manufacturing.

Solution
A solution is the successful result of an analysis, or imported results available for plotting.
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Windows in Ansoft Designer
Windows in Ansoft Designer

Project Manager
The project manager shows the projects loaded in to Ansoft Designer. Each project may consist of 
one or more circuit, system, or planar EM designs. Each design’s data, such as model data 
1 - 4 Introduction 



Windows in Ansoft Designer
information, ports and excitations, analysis setup information, and graphs, are displayed as entries 
in a separate subtree in the project manager.

Information contained in the design is organized into folders:
• Data—Substrate data, library references, netlist fragments, and so on
• Excitations—Sources in the circuit
• Ports—Ports in the circuit
• Analysis—Setup information to perform various analyses
• Optimetrics—Setup information to perform optimization, statistical analysis, and so on
• Results—Collection of graphs and tables for the design
• Definitions—The collection of components, symbols, footprints, and so on, accessible from 

Ansoft Designer
Double-clicking an item in these folders typically opens a dialog used to set the properties of that 
item.
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Windows in Ansoft Designer
Right-clicking a folder or item pops up a shortcut menu that allows you to perform various 
operations. For example, right-clicking the design icon for a circuit design displays this menu:

Virtually all project editing and management can be done from the Project Manager window 
using the right mouse button shortcut menus. Many of these menus are also available from the main 
menu bar in the Circuit, System, or Planar EM menus.
The Components tab near the bottom of the Project Manager window allows you to browse and 
select schematic components to place. It is organized by design type (circuit or system) and by 
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Windows in Ansoft Designer
component function. For example, the microstrip library has a number of categories and the set of 
bend components is expanded:

You can launch online help for a component from the Components tab of the Project window. To 
do this:
1. Right-click its icon.
2. Click View Component Help.
To place a component, you can either:
• Double-click its icon.
• Select, drag, and drop a component in the schematic editor.
• Right-click its icon, and then select Place Component.
Move your cursor to the schematic window. Now the cursor is accompanied by the symbol of the 
component you chose to place. You can rotate the component by pressing the R key.
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Windows in Ansoft Designer
To place the component, click where you want to place it. You can continue to place additional 
copies of the same component by clicking at additional locations. To stop placing components, do 
either of the following:
• Press the ESC key
• Right-click in the schematic and select Place and Finish, Finish, or Cancel.
If you prefer not to use the multiple-placement feature, you can turn it off as follows:
1. On the Tools menu, select Options, and then click Schematic Editor Options.
2. Select the Multiple Placement tab.
3. Clear the check box for each schematic item for which you want to turn multiple placement 

off.
4. Click OK.
The Components tab also includes a list of Most Recently Used (MRU) components and 
Favorites. The MRU list shows the last 10 unique components used.
To add a components to Favorites, right-click it and select Add to Favorites. This is a very 
convenient way of accessing commonly used components rather than navigating through the 
component tree repeatedly.
The Search tab allows you to enter full or partial names of components and search for them. This 
can be useful if you know some part of the name of the component you want to find.
The Project Manager window is a dockable window. It can be moved and sized any way you want 
it and it can attach itself to any edge of the Ansoft Designer desktop. There are controls on the 
window when it is docked, as shown below:

Property Window
The Property window shows the properties of objects selected in the schematic and layout editors, 
and objects in the Project Manager window. It allows you to modify property values. The Param 
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Windows in Ansoft Designer
Values tab lists the simulation parameters of the component or components selected. The General 
tab lists the selection’s name, symbol name, reference designator, and so on. These are generally 
not editable.

The Symbol tab provides information on the location of the component symbol in the schematic. 
The Property Displays tab lists the properties of the component that appear on the schematic, for 
example, C = 10pf for a capacitor. By clicking in the visibility box, you can choose how this 
information is displayed: None results in no label being shown; Name results in just the component 
name, i.e. C; Value results in just the component value, i.e., 10pf; and Both results in both the 
name and the value, i.e. C = 10pf being shown. This can be used to customize what the schematic 
looks like, which can be useful for very complex circuits where both Name and Value may be 
unnecessary.

Moving the Property Window
The Property window is a dockable, resizable window and can be positioned elsewhere on the 
desktop, as you may find convenient. You can change the relative widths of any two adjacent 
columns in the Property window by dragging the header separator between them:

Launching Online Help from the Property Window
You can launch the online help for a component from the Property window. To do this:
1. Click the Param Values tab.
2. Locate the Info parameter entry, and then click the button in its Value cell:

Properties Dialog Box
Like the Property window, the Properties dialog box shows the properties of selected objects, 
and, where appropriate, allows editing the values of these properties. It is an expansion on the 
Property window in that it allows access to additional editing commands, and to settings for 
tuning, optimization, sensitivity, and statistical analysis, that are not available through the 
Property window.
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Windows in Ansoft Designer
To open the Properties dialog for a component, double-click the component.

The Parameter Values tab lists the simulation parameters of the component or components 
selected. The General tab lists the selection’s name, symbol name, reference designator, and so on. 
These are generally not editable. The Symbol tab provides information on the location of the 
component symbol in the schematic.

Hints • You can resize the Properties dialog box by dragging its edges.
• You can change the relative widths of adjacent columns in the Properties dialog 

box by dragging the header separators between them:
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Windows in Ansoft Designer
Message Manager
The Message window shows error and informational messages about various processes in Ansoft 
Designer. These are often related to the status of a simulation, including any errors it may have 
produced.

Messages are organized by project, and then by circuit. Because a design can contain multiple top-
level and subcircuits, and multiple analyses can be set up for each, this organization helps you 
determine where errors have occurred.

Clearing Messages
The Message Manager clears at the start of each analysis. To manually clear messages, right-click 
the message tree and select Clear Messages for <ProjectName>, where <ProjectName> is the name 
of the project for which you want to clear messages.

Hiding the Message Window Until Messages Appear
If you prefer to hide the Message Manager until a message is added:
1. Click Tools>Options>General Options.
2. Select Show message window on new messages.
You can now close the Message window and it will re-open when Ansoft Designer reports any 
errors, warnings, or successful completion of any simulations.

Moving the Message Manager
The Message Manager window is a dockable window. It can be moved and sized any way you 
want it and it can attach itself to any edge of the Ansoft Designer desktop. There are controls on the 
window when it is docked.

Schematic Editor
The Schematic Editor window allows you to place components and wire them together. You can 
move components by simply selecting and dragging them. Copy and paste can be used on 
components and their wires within the schematic editor. You can also copy and paste to other 
schematics.
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Windows in Ansoft Designer
As you place the cursor near a pin of a component, it changes from an arrow to an X. This indicates 
that the schematic editor is in the wiring mode. In the wiring mode, left-click to start drawing a 
wire. Left-click again to end the wire.

Commonly used items such as ports, n-port black boxes, grounds, and page connectors can be 
placed in the schematic by clicking their toolbar icons or by using the Draw menu.
View controls to zoom in, zoom out, and fit the drawing to the editor window are available on the 
View menu, and on the shortcut menu that opens when you right-click in a schematic.

Layout Editor
The layout editor shows the physical realization of the circuit. Components such as transmission 
lines will be drawn on the metal layer. Components that don’t have footprints, such as ideal 
capacitors, will be represented in the layout as schematic symbols to indicate that no footprints are 
associated with them. Arbitrary graphical primitives unrelated to modeled elements can also be 
drawn.
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Windows in Ansoft Designer
When components with footprints are added to a layout or modified, their footprint connection 
points may no longer be properly aligned with those of other components. To correct this 
misalignment, click Align Mw Ports on the Draw menu.

3D Layout Viewer
Once you have defined a layout and its layer stackup, you can view the entire structure in 3D by 
doing either of the following:
• On the Circuit menu, click 3D Viewer.
• Right-click the design in the project manager, and then click 3D Viewer.
The view can be rotated, zoomed, spun around, and animated.

Results Windows
When a design has been successfully simulated, you can generate results in a wide variety of forms, 
including XY, polar and 3D graphs; Smith charts; and data tables. Various attributes of each can be 
customized to your liking.

Progress Window
When a simulation is started, the progress window becomes active. Each simulation run will have 
its own progress bar. Right-clicking the bar allows you to abort the simulation or view simulation 
details.

You can configure the Progress window to appear only when a simulation is running. To do this:
1. Turn off the Progress window display by clearing the Progress Window setting on the desk-

top’s View menu.
2. On the desktop’s Tools menu, choose Options, and then click General Options.
3. On the Project Options tab, select Show Progress Window when starting a simulation.
4. Click OK.
The progress window is also a dockable window, so you can position it where you like.
Now that you’ve gained experience with the essentials of Ansoft Designer’s desktop and windows, 
you’re ready to explore how to set up linear analysis in Ansoft Designer. The Planar EM and 
System simulators are described later in this Getting Started guide. Each of the three chapters 
describing the Circuit, Planar EM, and System simulators can be studied independently if desired.
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2
Circuit Design
This topic shows you how to get started with Ansoft Designer’s schematic editor and Circuit 
simulator by building and analyzing basic linear and nonlinear circuits. Its coverage assumes that 
you are already familiar with the basics discussed in the Introduction to Ansoft Designer topic.
As you work through this Circuit Design topic, you will:
• Gain experience with linear circuit simulation in the Ansoft Designer design environment 

through constructing and simulating a 5-GHz bandpass filter.
• Learn how to report simulation results using Ansoft Designer’s post processing functions.
• Learn how to validate a Circuit design with Ansoft Designer’s Planar EM structure simulator.
• Gain experience with nonlinear circuit simulation through constructing and simulating a 

single-diode mixer.
• Learn how to set up parameterized subcircuits through constructing a two-level circuit 

hierarchy.
The first step is to start Ansoft Designer if you have not already done so.

Example: An Edge-Coupled Bandpass Filter
This section will guide you through building and analyzing a simple example while demonstrating 
basic features, and some advanced features, of Ansoft Designer.
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Example: An Edge-Coupled Bandpass Filter
The filter was synthesized in the Filter Design tool within Ansoft Designer, but instead of simply 
creating the design from the synthesis tool, we will construct it manually to show the basic steps.
1. Start Ansoft Designer: On the File menu, click New .

A new project is added to the project tree. It is named Projectn by default, where n is the order 
in which it was added to the current session of Ansoft Designer.

2. Select the new project’s name in the Project Manager window.
3. On the Project menu, click Insert Circuit Design .
4. In the Choose Layout Technology dialog box, select MS - RT_duroid 5880 (ER=2.20) 

0.020 inch, 0.5 oz copper, and then click Open.

A new, empty schematic, associated with RT Duroid 5880 technology, opens in the Ansoft 
Designer schematic editor.

Note If you want to open a new schematic that is not associated with the set of definitions 
that come with a technology file, you can click None rather than selecting a technology 
and clicking OK. This is useful for basic concept designs that do not or need not contain 
manufacturing or substrate information.
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5. On the desktop’s Schematic menu, click Layout Stackup .
Note that the stackup has the RT Duroid 5880 substrate material and 0.5-ounce copper for the 
signal layer:
The Stackup tab shows the material layers upon which the filter will sit. There is a 
copperinfinite ground (metallized signal) layer with zero thickness. On top of the ground is a 

Rogers substrate (dielectric), which is 20-mil thick. Finally, on top of the substrate is a trace 
layer that will consist of the metal outlines required for the filter, which is 0.675-mil-thick 
copper (0.5-oz copper.)
In this picture, the Material column has been resized for better readability.

6. Click OK.
7. You can also expand the default project name in the project tree and the Circuit1 Data icons to 
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reveal the substrate defined in the technology file:

The asterisk after the default project name indicates that the contents of the project have 
changed—with your addition of Circuit1 at step 4—since it was last opened or saved. Don’t 
save the project just yet; we’ll do that shortly.

8. Double-click the Duroid5880 substrate icon to view the substrate detail:
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Note that the dielectric information is visible but inactive. This indicates that this substrate 
definition is referencing a layer in the stackup. The metallization is also referencing the Trace 
layer. You can edit either of these reference-based definitions by clicking its associated Edit 
button, but doing so will break the connection to the physical stackup.

9. Click OK.

Build the Circuit Design
We will now place the components in the schematic. 
1. Click the Components tab of the project manager, and expand the Microstrip folder and the 

Coupled Lines icon:
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2. Find the component MS Coupled Lines w/Open Ends, Symmetric, five up from the bottom 
of the Coupled Lines list. Select the coupled line component and drag it across to the 
schematic window. Place four of these components in the schematic so the first and second, 
and the third and fourth, are positioned apart, with the second and third connected:

3. Expand the component group called _General Components. Select the MS Step component 
and drag it across to the schematic window.
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4. Place one step between the first and second couplers, and a second step between the third and 
fourth couplers. When placing the second step, press the R key twice to rotate it so it is turned 
around. Then, select the second step and click the Flip about X toolbar icon .
The schematic should now look like this:

Add Ports
Add two ports by doing the following:
1. Click the Port toolbar icon .
2. Click to place the port to the left of the first coupler section.
3. Double-click the port symbol.

The Port Definition dialog opens. In this dialog, you can modify the port’s name, termination, 
and other characteristics. For now, leave the termination set to 50 ohms.
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4. In the Symbol group, click Microwave Port:

5. Click OK.
6. Use this procedure to place a second port at the filter output.
7. Right-click the second port, and select Flip about Y.
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Example: An Edge-Coupled Bandpass Filter
The schematic should now look like the following:

Add Variables
Since the dimensions of edge-coupled filters are symmetrical, we will use variables to define the 
transmission line widths, lengths and spacings.
1. From the Circuit menu, select Design Properties.

Variables can be defined in two Design Properties tabs. The first tab, Parameter Defaults, 
defines parameters for which values can be passed into the design when it is inserted into a 
parent circuit as a subcircuit. The second tab, Local Variables, defines variables that are only 
accessible in this design.

2. Click the Local Variables tab, and then click Add.
The Add Property dialog box opens.
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3. Type W1 in the Name box and 0.645mm in the Value box, and then click OK.

4. Keep adding variables until you complete this set:

5. Click OK to close the dialog box.

Assign Variables to the Components 
1. Select the first and fourth coupled line components by pressing the CTRL key as you click 

them. 
• Alternatively, right click the two selected components and bring up the Properties dialog.
The Properties window now shows the parameters for both components. 

W1 0.645mm

W2 0.780mm

S1 0.197mm

S2 0.621mm

P1 11.0mm

P2 10.95mm

Note Whether you are defining project, local, or parameter variables, intrinsic names (f, freq, 
lb, etc) are reserved and cannot be used or entered into the source and port diaglogs. 
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2. Working in the Properties window, enter the values W1, S1, and P1 for W, S, and P:

3. Next, select the two inner coupled line sections and change their parameter values to:

4. Select the two step components, and then change their parameter values to:
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Now the schematic has all parameters assigned:

5. Next, we’ll change the schematic name from Circuit1 to BandPass5880:
a. Click the Circuit1 icon in the project tree, and then click its name.

The name label turns into a text box, with the existing name text selected for editing.
b. Type BandPass5880, and then press ENTER.

6. On the File menu, click Save. Type BPFilter5880 into the File name box, and then click 
Save.
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Set up the Circuit Analysis
We must add an analysis setup before we can analyze the filter circuit. 
1. On the Circuit menu, click Add Analysis Setup . The Analysis Setup dialog box opens:
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2. We want to perform a linear network analysis in the frequency domain, so click Next.

3. Select the sweep variable name F, and then click Edit:
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The Add/Edit Sweep dialog box opens:

Enter these three frequency sweep values:

When you’re done, click Add, click OK, and then click Finish.

Start 4 GHz

Stop 6 GHz

Step 5 MHz
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Start the Circuit Analysis
Start the Circuit Analysis
• To start analysis, click Analyze on the desktop’s Circuit menu. 

The Progress window activates to show how much of the analysis has been completed:

Once analysis is completed, a message is placed in the Message window indicating that the 
analysis was successfully completed. Should any errors occur, messages about them will be 
shown too.

In this picture, the BPFilter5880 icon has been expanded to show the message text.
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Working with Post Processing
1. To create a graph, click Create Report on the Circuit menu. The Create Report dialog box 

opens:

We will plot S parameters in a rectangular (XY) graph, so the default Display Type selection 
is fine. You can also report circuit performance in polar and Smith graphs, and on table 
listings, by selecting a different display type.

2. Click OK. 
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Start the Circuit Analysis
The Traces dialog box opens:

3. To quickly plot S parameters for the bandpass filter, multiselect S11 and S12 (click S11, and 
then click S12 while pressing the CTRL key), and then click Add Trace. This creates two 
entries in the trace definitions list at the top of the dialog:

4. Click Done.
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The graph of S11 and S12 opens:

The Traces Dialog Box
The Traces dialog is organized to provide the flexibility to define a great many different graph 
types while keeping the task of creating simple graphs quick and direct. The controls and options in 
the Traces dialog box include:
• Design—If the project has multiple top-level designs, selects the desired design.
• Solution—If the design has multiple analysis setups, selects the desired analysis.
• Domain—Selects a report domain (including frequency, time, spectral, and sweep) from 

among choices that depend on the analysis type and setup.
• Sweeps tab—Allows you to select sweep variables and determine their ordering in trace 

specification.
• X, Y tabs—These specify the calculation to be plotted against the X and Y axes.
• Category—Lists groups of responses and calculations so you can easily find them.
• Quantities—Lists the responses and calculations available from the simulator for each 

category.
• Functions—Allows you to apply common math functions to response calculations.
The available trace operations include:
• Add Trace—Adds a trace as defined in the Sweeps, X, and Y tabs.
• Add Blank Trace—Add a blank to the list of traces to be used for editing.
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• Replace Trace—Replaces the selected trace definition with the trace defined in the Sweeps, 
X, and Y tabs.

• Remove Trace—Deletes the selected trace definition.
• Remove All Traces—Deletes all trace definitions.
• Y-axis—Selects the Y-axis (Y1 through Y4) to which the selected trace is assigned. Click in 

the Y-axis value cell to select the desired Y-axis.
Note that the text in the X and Y trace columns is editable, so you can manually type or modify any 
trace definition. Ansoft Designer validates your manual input as soon as you click out of an edited 
field.
There are a number of attributes you can control from within a graph, such as changing colors, line 
widths, axis scaling, and so on. These features can be accessed three ways:
• Double-click a trace. A properties dialog box opens, giving you access to the trace’s color, line 

width, and symbol settings.
• Double-click the graph’s X or Y axis. A properties dialog box opens, giving you access to 

settings to the axis’ color, scaling, and unit settings.
• Double-click the graph’s background, border, or grids. A properties dialog box opens, giving 

you access to settings for the colors and, if appropriate, line style of the selected object.
A number of operations are available from the graph shortcut (right-click) menu:

• Modify Report—Opens the Traces dialog box for the current graph.
• Zoom In/Out/Autoscale—Magnifies a portion of the graph, or autoscales the view.
• Trace Type—Enabled when a trace is selected. Modifies the method of viewing the trace.
2 - 20 Circuit Design 



Start the Circuit Analysis
• Data Marker—Puts a tag on the trace to mark a specific point.
• Mark All Traces—Displays values for corresponding data points of multiple traces. Also 

finds minimum and maximum values for a single trace or a family of traces.
• Arrows—Displays arrows on the trace to show increasing calculation index.
• Add Label—Puts a text label in the graph.
• Delete—When a trace is selected, deletes the trace.
• Delete All Tags—Deletes all data markers and their legends.
• Accumulate—Keep prior traces on the graph up to the accumulate depth.

• Print—Prints the graph.
• Copy to Clipboard—Copies the graph on the clipboard for pasting into other applica-

tions.
Numerous other default options, such as table fonts and trace colors, can be modified in the Report 
2D Options dialog.

Modify the Data Markers
1. Select Data Marker, and you’ll see a small marker on the first trace. 
2. Select the S12 trace legend to put the data marker on that trace. As you move the cursor, the 

data marker follows it. You can also use the keyboard arrow keys to move the marker left and 
right and between traces.

3. Position the marker near the lower-frequency –3-dB point and click (or press the T key). A tag 
will appear. 

Note  You can set the accumulate depth as follows:
1. On the Tools menu, point to Options, and then select Report 2D Options.
2. Select the General Option tab.
3. Type a value in the Accumulate Depth box.
4. Click OK.
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4. Move the marker over to the second –3-dB point and click again; a second tag will appear as 
shown.

5. Exit marker mode by either clicking the right mouse button to bring up the popup menu and 
select Exit Data Marker, or press the Esc key.

6. To delete data markers from the graph, do either of the following:
• Click a tag legend you want to delete, and press DELETE.
• Right-click in the graph, and select Delete All Tags.

Tuning
Tuning provides an interactive means of changing a design’s variables or component values and 
immediately viewing the results. In this example, all our component parameters are set by 
variables, so we will only tune the variables.
1. On the Circuit menu, click Design Properties.
2. Click the Local Variable tab.
3. Select the Tuning option.
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4. You can select any of the variables to include in tuning. For now, select Include for W1, W2, 
P1, and P2.

The minimum and maximum values are automatically set to be 0.5 and 1.5 times the nominal 
value. You can change them if you want to.

5. Click OK
6. On the Circuit menu, click Tune.

The Tune dialog box appears.
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The main part of the dialog consists of the tune variable sliders. With Real Time selected, Ansoft 
Designer performs a new analysis each time you move, and as you move, a slider to a new value. 
You can also set up a sweep of a tune variable by selecting its Sweep check box. To remove a tune 
variable from the dialog box, click its close button.
Selecting Real Time indicates that the program will do an analysis and update the graphs each time 
a slider is moved. Clearing Real Time allows you to position the slider without performing an 
analysis until the Tune button is clicked.
If the BandPass5880 design included simulation setups other than NWA1, the simulation setups list 
would include them, and the Tune check box would be selected for each by default. The state of the 
Tune check box for an analysis determines whether or not tuning will be performed for that 
analysis.
Briefly, the other tune controls include:
• Tune–Performs an analysis.
• Abort–Stops the analysis.
• Save–Saves the current state (values) of the tune variables and names this state. Optionally 

applies to the design the new values achieved through tuning.
• Revert–Restores a saved state.
• Reset–Reverts the design to the original tune variable values.
• Close–Closes the tune session. As the session closes, you will be asked if you want to apply 

the tuned values if you have not already done so.
7. Move the sliders and watch the graph change. You can edit the design, change its properties, or 

change the analysis setup while the tune dialog box is active. So, for example, you may want to 
reduce the number of analysis frequency points for faster tune updates.

8. When you are finished, click Close. 
9. You are then given the option to apply the tuned values to your design. For this example, select 

Don’t Apply.
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Finalize the Physical Layout
Now that we have entered and analyzed the circuit, and have verified that its behavior is acceptable, 
we are interested in viewing and finalizing the physical layout of the circuit. 
1. On the Circuit menu, click Layout Editor .

The Layout window opens, displaying a group of primitives as in the picture below:

2. All the coupled sections are there, but they are not aligned. That is, their connection points are 
not physically touching with the correct orientations. To correct this:
a. Select all the items in the layout (press CTRL+A or draw a selection box around all of the 

sections).
b. On the Draw menu, click Align Mw Ports  or press the Ctrl+M.
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The layout should now look like:

3. You can also view the 3D image of this layout:
a. On the Circuit menu, click 3D Viewer.
b. Use commands on the 3D Viewer right mouse shortcut menu to zoom, rotate, and pan the 

image. The 3D Viewer shortcut menu is also available when you right-click the layout 
window.
• Alternatively, press Alt + Shift and move the mouse to zoom, press Alt to rotate, or 

press Shift to pan.
c. Return to the regular layout view by clicking Layout Editor on the Circuit menu.
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d. Make sure you are viewing the Planar EM design: Click the Planar EM design in the 
project tree.

Exporting to Planar EM Analysis
We can verify the design using electromagnetic (EM) planar analysis. To do this, we must first 
export the circuit layout geometry using Ansoft Designer’s Copy to Planar EM command. We can 
copy all of the layout geometry to Planar EM or only a portion. In this example, we will copy 
everything to Planar EM.
1. Return to the layout editor by selecting the layout window from the Window menu.
2. Select all of the items in the layout window by pressing Ctrl+A or by drawing a selection box 

around all the items.
3. On the Edit menu, click Copy to Planar EM. 

A new Planar EM design is added to the project. It is equivalent to the circuit design just 
created.
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The filter geometry is now available in the Planar EM layout editor. Since both Circuit and Planar 
EM layouts are identical, care must be taken when viewing and editing the two designs. The Circuit 
design is known as BandPass 5880, while the equivalent Planar EM design is known as 
_EM_BandPass5880. The two layout windows are listed on the Window menu.

Items to consider when copying Circuit layouts to Planar EM:
• Hierarchical designs will be flattened.
• Parameterized designs will remain parameterized.
• Port definitions will be maintained as much as possible.
• Scripted footprints will be instantiated and will no longer be scripted.

Compare the Planar EM Model to the Circuit Analysis Results
To compare the behavior of this model to the Circuit analysis results, we must add 50-ohm 
feedlines to each end of the filter. Otherwise, the EM analysis will terminate the ports in their 
characteristic impedances, giving results that cannot be validly compared with those from the 
Circuit analysis of the filter.
1. First, remove the ports from the Planar EM design because they are not 50-0hm ports:
• Select the ports one at a time in the Excitations folder of the Planar EM design in the 

project tree, and then press Delete.
2 - 28 Circuit Design 



Start the Circuit Analysis
2. On the Draw menu, select Primitive, and then click Rectangle to change to the Rectangle tool 
. Then:

a. Make Trace the active layer by clicking it in the Active Layer pull-down list in the menu 
bar:

b. Draw a rectangle, and then edit its properties to make it 5 mm wide and 1.58 mm high.
This makes 50-ohm line.

c. Place the line at the input to the filter, carefully aligning it with the input portion of the 
coupled lines.

d. Copy the line by pressing Ctrl+C, paste it by pressing Ctrl+V, and add the copy to the other 
end of the filter. Your drawing should look like this:

3. The lines just added must be merged with the line segments they adjoin. To do this:
a. Multiselect the left 50-ohm line and the coupler line it adjoins. (Press and hold CTRL, 

click one structure, and then click the other.)
b. On the Layout menu, select Merge Polygons, and then click Union.
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c. Do the same with the right 50-ohm line and the coupler line it adjoins.
4. Next, we must add ports. To do this:

a. On the Edit menu, click Select Edges .
b. Move the cursor close to the left edge of the filter. As the cursor nears the edge, it changes 

to a solid arrow touching an oblique line, indicating that you can select the edge:

c. Click to select the edge:

5. On the Draw menu, click Edge Port .
The selected edge becomes a port.

6. Do the same on the other side so that you have two ports.
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Your Planar EM design should now look like this:

The Project window has been updated to show the addition of the two new ports. Expand the 
PlanarEM design, and then expand the Excitations listing in the tree to see the two new ports 
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listed. The properties of the ports can be accessed by double-clicking on the port name.

Now that we have equipped the filter model with ports, we can analyze it to compare its 
behavior to its Circuit counterpart.
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Set up and Solve the Planar EM Analysis
1. On the Planar EM menu, point to Analysis Setup, and then click Add Solution Setup .

We will accept the default values shown in the resulting dialog box, Setup 1. The most critical 
parameter is the mesh frequency, for which the default value of 10GHz will be automatically 
adjusted to 6GHz when we add a frequency sweep in the next step.

2. Click OK.
3. On the Planar EM menu, point to Analysis Setup, and then click Add Frequency Sweep 

.
The Sweep 1 dialog box opens.

4. In the Type group, select Interpolating Fast.
5. In the Sweep Description list, select the default entry, and then click Delete.
6. In the Specify Frequency Sweep group, select Linear Step.
7. Enter these sweep definitions:

Start 4 GHz

Stop 6 GHz

Step 5 MHz
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8. Click Add. The sweep specification should look like this:

9. Click OK.
10. On the Planar EM menu, click Analyze .

As the EM solver computes the model, the progress bar indicates its activity:
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Advanced Note on Geometry Alignment:
If the analysis deliberates for more than a minute at 4.0 GHz, or if Ansoft Designer displays an 
error that says that ratio of the mesh size is too large, the 50-ohm line sections are not properly 
aligned with the coupler input sections. To fix this:
1. Go to the project tree and expand the analysis icon so you can see Setup 1.
2. Right-click the Setup 1 icon, and then select Mesh Overlay.

Notice that the mesh density varies in regions associated with sudden changes in line width, 
such as the junctions between coupler lines of different widths.

3. Zoom into the area where one of the added 50-ohm lines adjoins the corresponding coupling 
input section. If you see a dense mesh, a small misalignment exists.

4. Use the editor to correct the alignment and check the other 50-ohm line for the same problem.
5. Right-click the Setup 1 icon, and then click View Profile. You can access a history of the 

current simulation as well as any previous simulations in the design. The profile includes a 
great deal of useful information, such as which machine the simulation ran on, the start time, 
stop time, and run time, the number of triangles in the mesh, and what frequencies were solved.

Create a Report of the Planar Results
1. On the Planar EM menu, point to Results, and then click Create Report.
2. In the Create Report dialog box, click OK.
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3. Working in the Traces dialog box, create a rectangular graph showing dB(S(Port1,Port1)) and 
dB(S(Port1,Port2)). Add the data markers as we did before. You should see:

The input match is slightly different, due to small differences in impedances in the coupled line 
section between the circuit and EM solvers. The calculated bandwidths are slightly different also:

Circuit Model EM Model
Fc1 4.70 GHz 4.75 GHz

Fc2 5.32 GHz 5.27 GHz

Bandwidth 0.58 GHz 0.52 GHz
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This reduction in bandwidth appears to be from the rounding of the passband in the EM simulation 
due to the difference in coupled line impedances from the Circuit analysis. Looking closely at the 
passband, we see:

The preceding plot was made by exporting the Planar EM solution, importing it into the Circuit 
analysis, and selecting the imported solution in the Traces dialog.
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Export the Planar EM Solution
1. On the Planar EM menu, point to Results, and then click View Profile .
2. In the Solution Data dialog box, select the Matrix tab, and then click Export.

3. In the Export NetworkData Solution dialog box, select Touchstone .sNp format (*.sNp) in 
the Save As type list, and then click Save.

4. Note the full pathname of the file you saved.
5. Click Close.
Note the several alternate formats that are available in the Save as type list for exporting the Planar 
EM solution.

Import the Planar EM Solution into the Circuit Analysis
1. Bring the filter circuit schematic to the top by clicking it, selecting its entry in the Window 

menu, or double-clicking its icon in the project tree.
2. On the Circuit menu, click Import Solution to import network data.
3. In the Import Solution dialog box ensure that Network Data is selected, and then click OK.
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The N-port Data dialog box appears:

4. Under Data Source leave Import Data selected.
5. Under File, leave Use Path selected.
6. Click the browse button to browse to the EM-exported data. 
7. Browse to the file you saved, and then click Open.
8. Click OK.

The solution object appears beneath the NWA1 object in the circuit project tree:
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The imported solution is now available as an option on the Solutions menu in the Traces 
dialog box:

Now that you’ve gained experience with linear analysis, you’re ready to explore how to set up 
nonlinear analysis in Ansoft Designer.
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Example: A Nonlinear Circuit
Example: A Nonlinear Circuit
This section describes building a simple nonlinear circuit and setting up analyses for it. The circuit 
is kept simple so we can concentrate on the aspects specific to nonlinear circuits. The circuit is a 
diode detector with bias.

Build the Design
1. Start Ansoft Designer, if it is not already running.

If Ansoft Designer is already running, create a new project by clicking New on the File menu.
2. Insert a Circuit design in the default new project or the project you created by selecting Insert 

Circuit Design on the Project menu.
3. In the Choose Layout Technology dialog box, click the None button. (We need not consider 

the physical layout of this circuit to explore nonlinear analysis, so the simplicity of a purely 
electrical simulation is acceptable.)

4. Click the Components tab in the Project window, and then locate and place the components 
below in the schematic window. Select and drag a component to place it in the schematic 
window. Press ESC to stop placement.

5. Also place ports as shown in the schematic below.

In this picture, the Symbol property for both ports has been set to Microwave Port, and Flip 
About Y Axis has been done for port 2.

6. Set the Port 2 termination to 1000 ohms, resistive, as follows:
a. Double-click the Port 2 symbol to open the Port Definition dialog box.
b. In the Termination group, type 1000 in the Re box.
c. Click OK.

Component Value Location Number
Capacitors 100pF Lumped, Capacitors, Capacitor 2
Inductor 100nH Lumped, Inductors, Inductor 1
Ground Draw menu and Schematic Draw toolbar 1
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7. On the Component Tab, expand the Nonlinear folder, then the Diodes folder.
8. In the Diodes folder, select and drag the Microwave Model component to place it between the 

shunt inductor and shunt capacitor in the schematic window, with its cathode end toward port 2
9. In the Diodes folder, select and drag Microwave Model Data to place this connectorless 

component somewhere on the schematic.
10. Open the Sources folder, and then the Independent Sources folder.
11. Select and drag the Voltage source and place it on the schematic with its positive terminal on 

the lower terminal of the inductor. Connect the other source terminal to ground.
12. Wire the diode as shown below.

The Model Data component specifies the device parameters for the diode. These parameters 
can be common to more than one instance of a diode, so they need only be specified once and 
can be referenced by as many diodes as desired.

13. Double-click the Model Data component, and then enter the following values:

The other parameters will take their default values.
14. Double-click the diode and enter the following values:

This links the diode to the model data block of the same name, demo.

Parameter Value
DeviceName demo

CT0 0.2p

Parameter Value
MOD demo
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Set up the RF and DC Sources
Next, we'll set up the RF and DC sources. We want to be able to sweep the RF power and the DC 
bias, so we need to set up two parameters, which we can then sweep. 
To set up the sources:
1. On the Circuit menu, click Design Properties. 
2. Ensure that the Value option is selected.
3. Click the Add button, and then enter this parameter:

4. Click OK to accept the entry.
5. Click the Add button again and enter this parameter:

6. Click OK to accept the entry.
7. Click OK to close the Properties dialog box.
8. Double-click the left port component.

This opens the Port Definition dialog box, through which you can add sources to the port. The 
default source type is Power.

Name Value
Pavs 10dBm

Name Value
Vbias 0V
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9. Click the Add button to add a source.

We'll keep the hnum (harmonic number) property set to f1, signifying that this source will be 
considered as tone 1 in harmonic-balance analysis.

10. For the value of p, type Pavs.
This sets the source power equal to the value of the Pavs parameter defined earlier.

11. Click OK in the Source Selection dialog box, and then click OK in the Port Definition dialog 
box.

12. Double-click the voltage source in the circuit.
The Source Selection dialog box opens.
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13. Set V to Vbias, and set the name of the source to bias:

Multi-Tone 
In addition to the Sinusoidal source type, a Multi-Tone type exists in the Source Selection dialog 
for use in defining ports. The Multi-Tone type has the same parameters as the Sinusoidal type with 
three additions:
• ncarries (number of carriers)
• cp (power per carrier) 
• deltaf (frequency separation between carriers)

Sampling Rate and Number
The Source Selection dialog also supports the following system port parameters for use in discrete 
time analysis:
• nsamp (number of samples)
• sample_rate (sampling rate)

Set up a Harmonic-Balance Analysis
1. On the Circuit menu, click Add Analysis Setup.
2. In the Analysis Type list, choose Harmonic Balance.
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3. In the Category list, click 1-Tone, and then click Next.
The Harmonic Balance Analysis, 1-Tone dialog box opens.

4. Set No. of Harmonics to 8.
5. In the Sweep Variables list, select F1, and then type 2GHz in the Sweep/Value cell.
6. Click Add.

The Add/Edit Sweep dialog box opens.
7. In the Variable list, select Pavs.
8. Ensure that Linear Step is selected, and then type −10dBm for Start, 10dBm for Stop, and 

1dB for Step.
9. Click Add.
10. Click OK.
11. Click Finish.

Rename and Save the Project
Now that the project’s setup is complete, rename the project and save it:
1. Right-click the circuit design in the Project window, and then click Rename.
2. Type NLdiode, and then press Enter.
3. On the File menu, click Save As.
4. Type NLdiode in the File name text box, and then click Save.

Analyze the Project
1. Expand the Analysis icon in the project tree.
2. Right-click the HB1Tone1 icon and then click Analyze HB1Tone1 on the shortcut menu.

Create Graphs of Results
With the analysis completed, we will create three graphs:
• Port 2 DC voltage at versus Pavs
• Time-domain voltage waveform across the diode for each value of Pavs
• Time-domain current waveform into the diode for each value of Pavs
To create the graph of Port 2 DC voltage versus Pavs:
1. In the project tree, right-mouse click this project’s Results icon, and then select Create 

Report.
The Create Report dialog opens.

2. Click OK.
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3. Select the following in the Traces dialog:

You must graph the real part of V2<DC> quantity because all harmonic phasor quantities are 
handled as complex numbers, including their DC components.

4. Click Add Trace.
5. Click Done.

You should see the following graph:

For this picture, we have renamed the graph by selecting its icon in the project tree, right-
clicking, selecting Rename, typing a new name, and pressing ENTER.

Domain Sweep
Category Voltage
Quantity V2<DC>
Function re
Circuit Design 2 - 47



Example: A Nonlinear Circuit
To view the linear region (in the logarithmic sense) of the detector's operation, change the Y axis 
scaling to logarithmic:
1. Double-click the Y axis to open the Y Axis Properties dialog box.
2. Select the Rescale tab, and then click Log.

3. Click OK.
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The rescaled plot should look like this:

The linear region extends to about −5dBm.
To create the graph of time-domain voltage waveform across the diode for each Pavs:
1. Start creating a standard, rectangular 2D report as described earlier.
2. In the Traces dialog box, select the following settings:

3. Click Add Trace. 
4. Click Done.

Domain Time

Category Voltage

Quantity Vac(D1)

Function none
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The resulting graph should look like this:

The graph clearly shows the clipping of the voltage across the diode at higher power levels. On 
the graph legend on the right-hand side, you can select the line for each level of Pavs, from -10 
dbm to 10 dbm, and it will be highlighted on the graph. You can scroll down through the Pavs 
levels by clicking the black rectangle at the top of the legend window. The legend window can 
also be resized by clicking the vertical divider and be moved left and right across the Results 
window.

To create the graph of the time-domain current waveform into the diode for each Pavs:
1. Right-mouse click the Results icon, select Create Report, and then click OK.
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2. Select the following in the Report dialog:

3. Click Add Trace.
4. Click Done.

The resulting graph should look like this:

The forward current through the diode is clearly visible during the time intervals in which the 
diode voltage is positive. The negative current and initial rise in forward current are due to 
energy storage in the diode capacitance.

Re-analyze the Circuit
First, make these changes:
• In the Diode Model Data component, set CT0 equal to 0.

Domain Time

Category Current

Quantity Ia(D1)

Function none
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• In the HB1Tone1 analysis setup, change the No. of Harmonics setting from 8 to 32. 
• Re-analyze the circuit. 

The previously created graph of current into the diode still exists and has been updated 
automatically with the new simulation data. To bring the graph up to the front, you can double-
click on the third graph under the Results item in the Project window. 
The current plot changes to:

This shows the ideally rectified current in the diode.
• Change CT0 back to 0.2p, and change No. of Harmonics back to 8.

Add a Sweep of the Bias Voltage
1. Double-click the HB1Tone1 analysis setup to open the Harmonic Balance Analysis, 1-Tone 

dialog.
2. Click Add.
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3. In the Variable list, select Vbias.
4. Specify a Linear Step sweep:.

5. Click Add, and then click OK.
The graph is now the original graph of current into the diode, which shows a linear frequency, 
a power sweep, and a voltage sweep.

6. Right-click the HB1Tone1 icon, and then select Analyze HB1Tone1.
7. Click the V2<DC> graph to bring it to the top, right-click in the graph, and then select Modify 

Report.
8. Click the Sweeps tab. If you don't see a Vbias entry, reselect the Solution entry for HB1Tone1 

to update the listing.
9. Click the Apply To All Selected Traces button to update the trace with the new sweep 

information.
10. Click Done. 

You should see a set of curves now, but the axis changed back to a linear scale. This is because 
some of the data is negative and cannot be plotted on a logarithmic scale. To remedy this, we 
can define a function that avoids negative voltages.
a. Right-mouse click on the graph and select Modify Report.
b. Enter the following expression in place of re(V2<DC>):

if(re(V2<DC>) < 1e-6, 1e-6, re(V2<DC>))
The IF function tests the condition in the first argument and if true, returns the value of the 
second argument; otherwise, it returns the value of the third argument. This expression 
states, “If re(V2<DC>) is less than 1E−6 (1 microvolt), then let the value be 1E−6, other-
wise use re(V2<DC>).”

Start −200mV

Stop 200mV

Step 100mV
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c. Click Done.
Now we can apply the log scaling to obtain this graph:

Perform a Transient Analysis
1. Right-click the Analysis icon in the project tree, and then select Add Analysis Setup.

The Analysis Setup dialog opens.
2. In the Analysis Type list, select Transient Analysis, and then click Next.
3. Type 50ns in the Length of Analysis box, and then type 20ps in the Maximum Time Step 

Allowed box.
4. In the Sweep Variables group, click Add.
5. In the Variable list, select Pavs.
6. Click Single Value, type 0dBm in the Value box, click Add, and then click OK.
7. In the Sweep Variables group, click Add.
8. In the Variable list, select Vbias.
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9. Click Single Value, type 0V in the Value box, click Add, and then click OK.
10. Click Finish.

11. When we set up the excitation source, we left blank the frequency field for transient analysis. 
To edit the source, do the following:
a. Expand the Excitations icon:

b. Double-click the Sinusoidal1 icon.
The Source Selection dialog opens.

c. Scroll to the f parameter, type 2GHz in its Value cell, and then click OK.
12. Right-click the Transient1 icon, and then select Analyze Transient1.
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Create a Rectangular Plot of Results
Create a standard rectangular plot after the analysis concludes.
1. Right-click the Results icon, and then select Create Report.
2. In the Traces dialog box, make these selections:

3. Click Add Trace.
4. Click Done.

The following graph will appear:

The solution reaches steady state at around 50 ns. To view a close-up of the waveform, right-
click, select Zoom In, and then drag a box around the region you want to magnify.

Now that you’ve gained experience with nonlinear analysis, you’re ready to explore how to set up 
and use hierarchical designs in Ansoft Designer.

Solution Transient1

Category Current

Quantity Id(D1)

Function None
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Creating Hierarchical Designs
A hierarchical design is a Circuit or System design that contains subdesigns—designs placed in it. 
Any number of hierarchical levels can be created, and any number of subdesigns can be placed in 
another design. The design at the top of such a structure is commonly called the top-level design or 
top-level circuit. A design that contains a subdesign is called the parent of that subdesign. 
Subdesigns can be subcircuits (Circuit simulations), subsystems (System simulations), or Planar 
EM simulations, depending on the parent design type:
• Circuit designs may contain subcircuits and Planar EM simulations
• System designs may contain subcircuits, subsystems, and Planar EM simulations

You can set up analyses at any level in a hierarchy, analyze, and then view results of the analyses. 
An analysis performed on a design at a level other than top includes that design and all of its 
subdesigns, if any, but not its parent design or designs at any higher levels.
All of the many possible analyses you may specify for various designs at different levels of a 
hierarchy are entirely independent. For example, you can set up a linear network analysis for a filter 
at an intermediate level of a hierarchy to obtain its S-parameters over a frequency range, and you 
can set up a spot-frequency nonlinear harmonic-balance analysis for the hierarchy’s top-level 
circuit. You can then analyze only the filter subcircuit without having to analyze the entire 
hierarchical design over the filter frequency sweep—or you can run just the harmonic-balance 
analysis without sweeping the filter. (Analyzing a subcircuit that contains nonlinear devices 
requires special attention, as the devices’ biasing and excitation may originate in higher-level 
circuitry not included in the analysis.)
There are two approaches to creating a hierarchical design: bottom-up and top-down. We will use 
Circuit designs to illustrate each.

The Bottom-Up Approach
1. Start Ansoft Designer, if it is not already running.

If Ansoft Designer is already running, create a new project by clicking New on the File menu.
2. Insert a Circuit design in the default new project or new project you created by selecting Insert 

Circuit Design on the Project menu.
3. Create a design at the project level by selecting Insert Circuit Design on the Project menu.
4. Repeat step 3 for each subdesign you will need.
5. To build the hierarchy:

a. Right-click a design icon in the project tree, and then select Copy.
b. Select the icon for the design into which you want to copy the subcircuit, right-click, and 

then select Paste.
The Synchronize Design dialog box opens. In this dialog box, you can select whether the 
subdesign will be incorporated into the hierarchy of which the parent is part (Incorporate, 
the default choice) or will merely be linked to it [Keep independent (black box)]. When 
choosing Incorporate, you can also specify a name for the new subdesign.
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c. Click OK.
A symbol representing the subcircuit appears in the parent schematic. You can place and 
wire it as desired.

The Top-Down Approach
1. Start Ansoft Designer, if it is not already running.

If Ansoft Designer is already running, create a new project by clicking New on the File menu.
2. Insert a Circuit design in the default new project or new project you created by selecting Insert 

Circuit Design on the Project menu.
This will be the top-level circuit.

3. For each subcircuit you will need in the top-level circuit:
a. Make sure the top-level circuit is active in the schematic editor.
b. On the Circuit menu, point to SubCircuit, and then click Add SubCircuit.

4. Repeat step 3 at each level of the hierarchy as needed.
5. To reuse subcircuits at multiple places in a design:

a. In the project tree, right-click the icon for a design you want to reuse, and then select 
Copy.

b. Right-click the icon for the design into which you want to copy the subcircuit, and select 
Paste.
A symbol representing the subcircuit appears in the parent schematic. You can place and 
wire the subcircuit as desired.

As you create subcircuits, you will probably want to rename them. To do this:
1. In the project tree, click the name of the icon for the design that you want to rename.
2. Click the icon name again.

The icon name changes to an editable string that you can modify. When you renamed the 
design name to your liking, press ENTER.

Ansoft Designer creates a generic rectangular symbol for each new subcircuit. You can customize 
the symbol for a subcircuit as follows:
1. Expand the folder in the project tree labeled Definitions, and then expand the Symbols 

subfolder.
2. Double-click the symbol icon that corresponds to the subcircuit symbol you want to edit.

The symbol opens for editing in Ansoft Designer’s symbol editor.
3. When you’re finished editing the symbol, click Update Project on the Symbol menu to 

propagate your changes through the project.
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Example: Hierarchical Schematic Editing
This exercise shows you how to build a simple two-level schematic using the top-down approach. 
The circuit is a simple design that demonstrates the basic procedure.
1. Start Ansoft Designer if it is not already running.

If Ansoft Designer is already running, create a new project by clicking New on the File menu.
2. Insert a Circuit design in the default new project or new project you created by selecting Insert 

Circuit Design on the Project menu.
3. In the Choose Layout Technology dialog box, click None.
4. Rename the design as Top by clicking twice on the design name in the project window.
5. Add a subcircuit to the top-level circuit:

On the Circuit menu, point to SubCircuit, and click Add SubCircuit.
6. Rename the subcircuit to Section by clicking twice on the name of the corresponding design 

icon in the Project window.
7. Click the subcircuit schematic window to make sure that the focus is in that window.
8. Click the Components tab in the Project window, expand the Lumped folder, and then 

expand the Inductors library.
9. Select and drag the Inductor component to place one inductor in the schematic. (Press ESC to 

end the multiple-placement mode if it’s enabled.)
10. Expand the Capacitors library in the Lumped folder.
11. Select and drag the Capacitor component to place a capacitor in the schematic, rotating it to 

vertical by clicking the R key.
12. Place two ports and a ground , and wire the circuit so it looks like this:
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13. Switch to the Top (parent) schematic. The addition of the two ports to the subcircuit makes two 
corresponding pins appear on the Section subcircuit symbol in the Top (parent) schematic. 
Add two ports and connect each to a pin so the Top schematic looks like:

Add an Analysis Setup
1. Make sure the Top circuit is active in the schematic editor.
2. On the Circuit menu, click Add Analysis Setup. 
3. Select Linear Network Analysis for Analysis Type and accept the default Category setting 
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of Frequency Domain, and set up a linear sweep from 0 to 1 GHz in steps of 10 MHz:

Analyze the Circuit
• On the Circuit menu, click Analyze .
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Create a Report of Results
1. On the Circuit menu, click Create Report .
2. Create a rectangular graph of dB(S21):

Now you will put more of these subcircuits into the Top circuit. 
1. Right-click the subcircuit U1: Section in the project tree, and then click Copy on the shortcut 

menu.
2. Right-click the Top circuit, and then click Paste on the shortcut menu.

If multiple placement is enabled for components, you’ll be able to place another copy of 
U1:Section in the schematic after placing the first copy. Click in the schematic window to 
place a second copy, and then end placement by pressing ENTER, SPACE, or ESC, or by 
right-clicking and selecting Place and Finish, Finish, or Cancel.
If multiple placement is not enabled, placement will end after you place the first copy of 
U1:Section into Top. To place a second copy, display the Edit menu, and then click Paste.

3. You should now see three instances (copies) of the Section subcircuit in the Top circuit. 
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Arrange them between the ports in a cascaded fashion to look like this:
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Re-Analyze the Circuit and Save the Project
1. On the Circuit menu, click Analyze . 

Now the graph looks like this:

2. Save the project by clicking Save on the File menu. Type “Hierarchial” into the File name 
box, and then click Save.

By selecting a design in the Project window, you can copy and paste single subcircuits or 
hierarchical circuits into other designs within a project or into other projects. It is all the same 
procedure.

Working with Parameter Defaults and Passed Parameters
Subcircuits can be parameterized, meaning that values for properties of components within them 
can be assigned to alphabetic or alphanumeric placeholders (parameters) for which values can be 
inherited (passed in) from their parents. A property value inherited in this way is known as a passed 
parameter.
Subcircuits cannot accept parameter values from their parents by default. You must enable 
parameter passing for every subcircuit component property the value of which you want set by the 
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subcircuit parent. To do this for a given property value, you must create a special placeholder called 
a parameter default, assign it a valid default value, and then use that parameter default as a value 
placeholder in a subcircuit component or components. This exercise demonstrates how to enable 
and use passed parameters in Ansoft Designer.
1. Select one of the subcircuits in the project tree, right-click it, and then select Design 

Properties:

The Properties dialog box opens.
2. Add a parameter default as follows:

a. In the Parameter Defaults tab, ensure that Value is selected, and then click Add.
The Add Property dialog box opens.
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b. Enter L1 for Name and 10nH for Value.
c. Click OK.
You have just defined a parameter called L1, with a default value, 10nH, that can be 
overridden with values passed in from the parent circuit on an instance-by-instance basis.
Before proceeding further, right-click each of the three Section subcircuit instances and select 
Design Properties, and then Design Passed Parameters, for each in turn. Note in the 
resulting Properties dialogs that L1 is listed as a parameter default, and as a passed parameter, 
for all three instances. This is so because all three Section instances are instances of the same 
subcircuit, and adding a parameter default to any one of the three therefore populates that 
parameter default to all three.
At this point, the Design Passed Parameters value of L1 is shown as the default value of 10nH 
for all three instances, but we will change that now.

3. Double-click the inductor in the subcircuit and edit its properties. In the Value cell for the L 
property, type L1. The value of L1 will now be used as the value of L for this inductor.

4. Click in the schematic window for the Top circuit—the parent circuit—to bring that window to 
the top of the Ansoft Designer desktop.

5. Double-click on the leftmost instance of the subcircuit to open its properties. The Parameter 
Values tab lists the passed parameter L1 with its default value of 10nH.

6. Change L1 to 2nH. Doing so checks the Override box, indicating that you have overridden the 
default value. Click OK.

7. Similarly, change L1 to 20nH for the middle Section instance and to 2nH for the rightmost 
Section instance.
To view the value of L1 being passed into a subcircuit instance, do any one of the following:
• Select the subcircuit instance in the parent schematic. The Properties window displays 

the local values of passed parameters in its Param Values tab.
• Double-click the subcircuit in the parent schematic. The resulting Properties dialog box 

displays the local values of passed parameters in its Parameter Values tab.
• Right-click the design icon for the subcircuit in the project window, that is, U1:Section, 

U2:Section, and U3:Section, and then select Design Passed Parameters. The resulting 
Properties dialog box displays the local values of passed parameters in its Parameter 
Values tab.
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8. Select the design icon for the Top circuit, right-click, and select Analyze. The graph updates 
with the new results.

Now that you’ve gained experience with hierarchical designs, you’re ready to explore Ansoft 
Designer’s planar electromagnetic simulator.
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Planar EM Design
The Planar EM simulator is the ideal tool for projects that involve full-wave or radiative effects. 
For example, a designer might use Planar EM to draw the physical layout, and simulate the 
electromagnetic properties, of a patch antenna or a millimeter-wave integrated circuit. You can use 
the Planar EM simulator to compute and display quantities such as:
• Characteristic port impedances and propagation constants.
• Generalized S parameters, and S parameters renormalized to specific port impedances.
• Basic far-field parameters for electromagnetic fields and antennas. 

Example: A Low-Pass Filter
This section will guide you through the physical design and EM analysis of a low-pass filter. As 
you follow this example step by step, you will:
• Start Ansoft Designer and explore the Planar EM tools (all the basics, as well as a few 

advanced features).
• Use each of the Planar EM toolbars.
• Learn some terms and concepts essential to planar EM simulation. These include selecting a 

Layout Technology File; inserting signal, ground, and substrate layers; drawing a layout; and 
assigning ports.

• Add a custom-defined dielectric material to the design.
• Use Create Report to display simulation results.

Set up the Planar EM Design
1. On the Windows taskbar, click Start, point to Programs, point to the Ansoft Designer folder 

icon, and then click Ansoft Designer. Alternatively, you can double-click the Ansoft 
Designer desktop icon.

2. On the Project menu, click Insert Planar EM Design. Alternatively, you can insert a Planar 
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EM circuit using either of these options:
• On the Project toolbar, click the Insert Planar EM Design icon.
• In the Project Manager window, right-click the Project icon, point to Insert, and then 

click Insert Planar EM Design.
3. When the Choose Layout Technology File dialog box appears, click None.

The Layout Editor window appears.
• All Planar EM designs must define a process topology (also called a stackup).
• Layout technology files provides a quick way to store frequently used process topologies. 

For example, a designer who frequently uses a specific substrate can pre-specify the 
correct materials and stackups with a single click.

• In this example, we will not use a layout technology file, but will define the topology or 
stackup manually.

4. Hide the Message Manager and Progress windows:
• On the View menu, make sure that the checkboxes for Message Manager and Progress 

are cleared. 
5. Set the default units:

a. On the Tools menu, point to Options, and then click General Options.
b. Select the Default Units tab.
c. In the Length list, select mm, and then click OK, leaving the other settings unchanged.

6. Configure Grid & Snap for the Layout Editor:
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a. On the Layout menu, click Grid & Snap.
The Grid dialog box opens.

b. In the Gridlines group, enter 10 for Major and 1 for Minor, making sure that the unit 
used for each is the millimeter (mm, the default setting).

c. In the Snapping group, enter 1 for Grid and 1 for Electrical, making sure that the unit 
used is the millimeter (mm, the default setting).
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Insert Layers
1. Access the Stackup tab of the Edit Layers dialog box by doing either of the following:
• On the Layout menu, click Layers .

The Edit Layers dialog box opens.
Click the Stackup tab.

• On the Layout toolbar, click the Stackup dialog icon.  
2. Insert an infinite ground layer:

a. In the Stackup dialog box, click Add Layer.
The Add Stackup Layer dialog box appears.

b. In the Name box, type g1.
c. In the Type list, select metalizedsignal.

d. Click OK.
3. In the Stackup tab of the Edit Layers dialog box:

a. Click Add Layer.
The Add Layer dialog box appears.

b. In the Name box, type d1.
c. In the Type list, select dielectric.
d. Click OK.

4. In the Stackup tab of the Edit Layers dialog box, change the thickness of d1 to 1.5 mm.
5. Insert a trace layer by doing the following:

a. In the Stackup dialog box, click Add Layer.
The Add Layer dialog box appears.

b. In the Name field, type t1.
c. In the Type list select signal.
d. Click OK.
e. If the stackup created is not in the correct order, you can rearrange it by selecting and 

dragging the selection handle in the left-most column using the mouse. Select and drag 
layer t1 above the dielectric layer. 
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The Stackup tab of the Edit Layers dialog box should now look like this:

Next, create a new dielectric material and assign it to d1:
1. In the Stackup tab of the Edit Layers dialog box, locate the d1 row, and click Rogers.

The Select Definition dialog box appears.
2. Click Add Material.

The View/Edit Material dialog box opens. 
3. For Material Name, enter my_d1, and as the Value for Relative Permittivity, enter 2.2.
4. Leave all other settings unchanged.

5. Click OK in the View/Edit Material and Select Definition dialog boxes to close each in turn.
The Stackup tab of the Edit Layers dialog box should now look like this:

6. Click OK to close the Edit Layers dialog box.
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Draw the Model
1. Switch the active layer to t1:
• On the Layout toolbar, select t1 from the list of layers:

2. Draw a rectangle:
a. Do either of the following:
• On the Draw menu, point to Primitive, and then click Rectangle.
• On the Layout Draw toolbar, click the Draw Rectangle icon .

b. Drag the cursor into the Layout Editor, and use the keyboard to enter the data: Start by 
entering its lower left-hand coordinates. In the Status Bar (located at bottom of screen) 
enter 0.0 for X and 0.0 for Y. Use the TAB key to move between entries and press ENTER 
to apply the new settings. 

c. Note that when entering data using the TAB key, press ENTER as soon as you enter the 
data in Delta Y, and do not tab into the Distance box. (Otherwise, the program may 
capture extraneous mouse movements that can impair your results.)

d. Complete the rectangle by doing either of the following:
• Enter Delta X = 20, Delta Y = 4.6, and then press ENTER.
• Drag the upper-right corner until Delta X = 20, Delta Y = 4.6. 

e. Fit the drawing to the Layout window by doing either of the following:
• Press CTRL +D.
• On the View menu, click Fit Drawing.

3. Draw another rectangle:
a. Click the Draw Rectangle icon , and snap the cursor to the lower-right corner of the 

first rectangle.
b. Drag the rectangle until Delta X = 2.1 and Delta Y = −10.5.

4. Draw a third rectangle (here we show how to enter the coordinates directly):
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a. Click the Draw Rectangle icon .
b. In the status bar, enter 21.05 for X and 0.0 for Y, and then press ENTER.
c. Enter 21.7 for Delta X and 0.7 for Delta Y, and press ENTER. 

5. Draw a polygon:
a. Click the Draw Polygon icon .
b. In the Layout editor, snap the cursor to the upper-right corner of the first rectangle (20.0, 

4.6). Note: If you let the mouse hover briefly over the target point, you will see the cursor 
jump to the snap point.

c. Click the upper-left corner of the third rectangle (21.05, 0.7). 
d. Click the lower-left corner of the third rectangle (21.05, 0).
e. Double-click the lower-right corner of the first rectangle (20.0, 0).
f. Press CTRL+D to fit the drawing in the Layout window.

At this point, your layout should look similar to this:

The fill pattern within the objects may be different.
6. Copy and paste the selected elements:

a. Select the polygon, first rectangle, and second rectangle by pressing and holding CTRL 
while clicking the three objects in turn. 

b. Copy the objects by pressing CTRL+C. Then click in the Layout window and press 
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CTRL+V to paste the objects into the layout, as shown.

7. Mirror and move the elements that you just pasted:
a. Make sure that all of the copied elements are still selected.

b. On the Layout Edit toolbar, click the Flip about Y icon .
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c. Move the mirrored objects so that they snap to the lower-right corner of the third 
rectangle. 

To position the objects exactly, click the Zoom Area icon  and drag a box around the 
portion of the layout you want to magnify.

d. Press CTRL+D to view the full geometry. It should look like this:

8. Draw the fourth rectangle:
a. Click the Draw Rectangle icon .
b. In the status bar, enter 29.3 for X and 0.0 for Y, and then press ENTER. 
c. Also in the status bar, enter 5.3 for Delta X and−10.5 for Delta Y, and then press ENTER.
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d. At this point, your layout should look like this:

Save the project:
1. On the File menu, click Save.
2. Type planarEM1 in the File name box, and then click Save.

Assign the Ports
1. Create Port1: 

a. On the menu bar, click Edit, and then click Select Edges.
Alternatively, on the Layout Draw toolbar, click the Select Edges icon .

b. Point the cursor to the left edge of the first rectangle and click. 

c. Click Draw and then click Edge Port. Note that Port1 appears in the layout editor. Also, 
in the Project Manager, an icon labeled Port1 appears under Excitations.

d. Alternative way to add an excitation (port): First select the edge and, in the Project 
Manager, right-click Excitations and then click Add Port.

2. Create Port 2:
a. Click the Select Edges icon , point the cursor to the right edge of the right-most 

rectangle, and click.

b. Click the Draw port icon (located on the Layout Draw toolbar :
3. Rename Port 1:

a. In the Project Manager, expand Excitations, and then right-click Port1.
b. Click Rename, enter p1, and then press ENTER. 

4. Rename Port 2:
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a. In the Project Manager, expand Excitations, and then right-click Port2.
b. Click Rename, enter p2, and then press ENTER. 

Display the Circuit Using the 3D Viewer
Explore the functionality of the 3D Viewer:
1. In the menu bar, click Planar EM and then click 3D Viewer. 
2. Right-click anywhere in the 3D View window, point to View, and then check out the various 
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options.

Set up the Planar EM Analysis
Add an analysis-setup:
1. You can add an analysis setup in either of two ways:
• On the menu bar, click Planar EM, point to Analysis Setup and then click Add Solution 

Setup.
• Or, in the Project Manager, right-click Analysis and then click Add Solution Setup. 

2. When the Setup dialog box appears, select Fixed Mesh and enter 5.0 GHz in the Frequency 
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text box. Note: There is no space between “5.0” and “GHz.”

c. Click OK to close Setup.

View the Mesh and Set Dynamic Mesh Updates
You can view the layout of the design in a planar or 3D view. On the Planar EM menu, click 
Layout Editor to view the planar view of the design. 
In the Layout Editor, you can view the mesh in either of two ways.
• Click the setup you added. Then, on the Planar EM menu, point to Analysis Setup and then 

click Mesh Overlay. Mesh Overlay is available when a setup has been selected in the Project 
Manager.
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• In the Project Manager, expand the Analysis folder (by clicking the + sign next to its icon), 
right-click the setup you added, and then click Mesh Overlay.

Set up the analysis for Dynamic Mesh Updates in either of two ways:
• On the Planar EM menu, point to Analysis Setup, and then click Dynamic Mesh Updates. 
• In the Project Manager, expand the Analysis folder (by clicking the + sign next to its icon), 

right-click Setup1, and then click Dynamic Mesh Updates. 

Set up Sweeps
Add an Interpolating Fast sweep: 
1. Open the Sweep1 dialog box in either of two ways:

• On the Planar EM menu, point to Analysis Setup and then click Add Frequency Sweep. 
• In the Project Manager, expand the Analysis folder, right-click Setup1, and then click 

Add Frequency Sweep. 
2. When the Sweep1 dialog box appears, select the default sweep and then click Delete.
3. Select Interpolating Fast.
4. Select Linear Count.
5. Enter the sweep parameters: 

a. In the Start, Stop, and Count boxes enter 1.5 GHz, 5 GHz, and 201. 
b. Click Add.
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• Alternatively, to update frequencies for an existing sweep, enter the new data in the 
Start, Stop, and Count boxes, and then click Update.

6. Click View Sweep Points List to display a tabular list of the frequencies used during the 
analysis.

7. Click OK to close the Sweep1 dialog box.

Add a Discrete sweep: 
1. Open the Sweep2 dialog box in either of two ways:

• On the Planar EM menu, point to Analysis Setup, and then click Add Frequency 
Sweep. 

• In the Project Manager, expand the Analysis folder, right-click Setup1, and then click 
Add Frequency Sweep. 

2. When the Sweep2 dialog box appears, select the default sweep and then click Delete.
3. Select Discrete, Generate Surface Current, and Linear Count. Generating surface currents 

enables you to view currents and field quantities in later steps.
4. Enter the sweep parameters: 

a. In the Start, Stop, and Count boxes enter 2.3 GHz, 2.7 GHz, and 5. 
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b. Click Add.
• Alternatively, to update frequencies for an existing sweep, enter the new data in the 

Start, Stop, and Count boxes, and then click Update.
5. Click View Sweep Points List to display a tabular list of the frequencies used during the 

analysis.
6. Click OK to close the Sweep2 dialog box. 

Run the Analyses
Run the analysis:
1. To sequentially run all of the sweep setups that exist in the design, do either of the following: 
• On the Planar EM menu, click Analyze. (Alternatively, in the Project Manager, right-

click Analysis and then click Start Analysis.)
• Or, you can run a single sweep: In the Project Manager, right-click the appropriate sweep 
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icon and then click Start Analysis. 

Note that it is also possible to run a single sweep: In the Project Manager, right-click the 
appropriate sweep icon (in this example, either Sweep1 or Sweep2) and then click Start 
Analysis.

2. Check the status while the analysis is running:
a. While the simulation is running, you can pause or abort the simulation by right-clicking 

the Progress window. (If the window is not visible, click View on the menu bar, and then 
then select Progress Window.)

b. To alter the priority of a particular simulation: Right-click the Progress Window, click 
Change Priority, and then select the appropriate setting (Normal, Lowest Priority, 
Highest, Above Normal, Below Normal).

c. The Clean Stop selection terminates the simulation when simulation for the current 
frequency point is completed.

Work with Post Processing
Use the post processing capabilities of Ansoft Designer to display the results of a simulation. You 
can also use the export features to save the analysis data (and an equivalent circuit) in various 
industry-standard file formats. 
Planar EM Design 3 - 17



Insert Layers
View Tabular S Parameters
Open the Solution Data dialog box:
1. In the Project Manager, right-click Sweep1, point to Results and then click Matrix Data.

The Solution Data dialog box appears. Your results will be similar to the following: 

2. Select S Matrix and then select the appropriate format (for example, Magnitude/Phase). 
3. Click Export, and the Export Network Data Solution dialog box appears. Select the 

appropriate format (for example, Touchstone, .SZG or .NMF) and then click Save. 
4. To export the circuit as an equivalent SPICE model, click Equivalent Circuit Export, select 

an appropriate file format and click Save. If the Equivalent Circuit Export command is 
unavailable, you need to obtain a license from your Ansoft representative.

5. To see runtime data pertaining to the analysis, click the Profile tab.

Plot Return Loss (S11)
To create a report:
1. First open the Create Report dialog box by doing either of the following:
• On the Planar EM menu, point to Results, and then click Create Report.
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• In the Project Manager, right-click Results, and then click Create Report.
2. Select Standard and Rectangular Plot. 
3. Click OK, and the Traces dialog box opens:

4. Plot the return loss:
a. In the Traces dialog box, select Setup 1: Sweep 1 in the Solution list. 
b. In the Category, Quantity, and Function lists select S Parameters, S(p1, p1) and dB.
Planar EM Design 3 - 19



Insert Layers
• Click Add Trace, then click Done, and the plot appears.

• Note that certain results (for example, S parameters) have Plot Templates that simplify 
the report-creation process. To use a template, select the appropriate sweep in the project 
tree, click Planar EM, point to Results, and then point to Display Templates and click 
the appropriate parameter.

• For additional details about formatting the plot (for example, labeling the axes and 
changing trace color) see Post Processing and Generating Reports in the online help 
topics.

Plot a User Defined Graph
Display a Smith chart for S(p1, p1):
1. On the Planar EM menu, point to Results, and then click Create Report. 
• Alternatively, in the Project Manager, right-click Results, and then click Create 

Report.
2. When the Create Report dialog box appears, select Standard and Smith Chart. 
3. Click OK, and the Traces dialog box appears.
4. In the Solution list, select Setup1:Sweep1. 
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5. In the Category and Quantity lists, select S Parameters and S(p1, p1), and make sure that 
None is selected in the Function list. 

6. Click Add Trace.
7. Click Done.

The Smith chart appears.

Rescale and Phase Animate the Currents 
Setup excitations: 
1. In the Project Manager, under Excitations, right-click p2, and then select Properties. 

The Edge Port Definition dialog box appears.
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2. In Port Excitation Magnitude, enter 0 ma and 0 degrees.
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Alternatively, right-click Excitations in the project tree, and then click Port Excitations on the 
shortcut menu. The Port Excitations dialog box appears, in which you can modify port excitations. 
This method would be convenient for multiple-port designs.
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Animate the currents:
1. Display currents: In the Project Manager, right-click Sweep2, point to Results and then click 

Display Currents.

2. In the Project Manager window, in the Results folder, right-click Setup 1: 
Sweep2:Currents, and then click Properties. 
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The Currents dialog box appears: 

3. Do the following:
• Under Scale, select Auto Scale and Logarithmic.
• Under Color Map, in the Ramp and Levels lists, select 21 and Temperature.
• Under Magnitude, in the Surface Deviation list, enter 3mm. 
• Leave the other settings unchanged, and click OK.

4. Phase animate the currents:
a. Under Results in the project tree, right-click Setup 1: Sweep2 Currents, and then click 
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Frequency on the shortcut menu. The Frequencies dialog box appears.
b. Select 2.7 GHz from the list. 

c. Right-click Setup1:Sweep2:Currents and then select Animate.
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The Setup Animation dialog box appears:

d. Do the following:
• Accept the defaults for Name (Animation1) and make sure that Phase is selected as 

the Swept Variable. 
• In the Start, Stop, and Steps boxes, enter 0deg, 360deg, and 40. 

e. Click OK.
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The resulting display looks like this:

5. In the Layout 3D window, right-click to Zoom, Rotate, or Pan the animation. 
6. Click Dismiss when finished.

Frequency Animated Far Field Plots
Far fields are not usually of interest when designing a filter, but the procedure is shown here for ref-
erence. To be able to plot the currents and far field, a discrete sweep must have been run, with Gen-
erate Surface Current selected in the solution setup, so that the currents are saved and are 
available to be plotted. As with the current animation, you can define the frequency at which you 
view the far field: Right-click Setup1:Sweep2:Far Field and click Frequency. Click 2.4 GHz.
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Plot the far field:
1. In the Project Manager, right-click Setup 1: Sweep2, point to Results, and then click Far 

Field:

The Layout 3D window appears and the far-field pattern is displayed. 
Also note that an icon is added in the Project Manager, under Results 
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2. Right-click anywhere in the Layout3D window, point to View, and then check out the various 
options.
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Animate the far field: 
1. In the Project Manager, under Results, right-click the Setup1: Sweep2: Far Field icon, and 

then select Animate.
The Select Animation dialog box appears:

2. Click New because you will view an animation of a varying frequency against a fixed input 
phase of 0 degrees.
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The Setup Animation window appears:

3. Accept the default name and swept variable.
4. Click OK and the animation begins. 
5. Click Dismiss when finished.
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Discrete Time Domain
Discrete time domain analysis yields the output signal response at arbitrary nodes in the system. 
This type of analysis can be applied to functional or mixed systems and is defined as follows:
• Functional system: contains only functional components 
• Mixed system: contains both functional and electrical components
During discrete time domain analysis, all electrical elements and subcircuits are converted to time-
domain models (uni-directional). The resulting time-domain model is extracted from the 
corresponding frequency response that is evaluated during the simulation. To do a system 
simulation, first create a project, then create a schematic within that project, and then run the 
simulation. 
The example presented in this section is a communications receiver with frequency and discrete 
time analysis setups. You will analyze and create output reports for each schematic after first 
running a simulation for each. 

Example: A Double Down-Conversion Receiver
This section shows you how to build the schematic, set up an analysis, and then create reports and 
display results. Along the way you will:
• Start Ansoft Designer and explore the system tools (all the basics, as well as a few advanced 

features).
• Use each of the system tools.
• Learn some terms and concepts essential to system simulation.
• Use Create Report to display the simulation results.
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Set up the System Design
To start Ansoft Designer:
1. Click Start.
2. Select Programs.
3. Select the Ansoft Designer folder.
4. Select Ansoft Designer.

5. On the Windows taskbar, click Start, point to Programs, and then point to the Ansoft 
Designer folder icon and click Ansoft Designer (alternatively, you can double-click the 
Ansoft Designer desktop icon). 

6. Start Ansoft Designer. On the File menu, click New.

7. Select the Project1 icon in the Project Manager window.

8. On the Project menu, click Insert System Design. 
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9. In the Choose Layout Technology dialog box, select PCB - DoubleSided and then click 
Open.

A new, empty schematic, associated with PCB DoubleSided technology, opens in the Ansoft 
Designer schematic editor.
If you want to open a new schematic that is not associated with the set of definitions that come 
with a technology file, you can click None rather than selecting a technology and clicking OK. 
This is useful for basic concept designs that do not or need not contain manufacturing or sub-
strate information.

Configure the Design Libraries
1. In the Project Manager window, click the Components tab and then determine if the Circuit 
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Elements folder is installed (if already installed, it appears under System Libraries icon): 

a. If the Circuit Elements folder is already installed in the Project Manager, then go to the 
next step. 

b. If the Circuit Elements folder is not installed, you must configure the Circuit Elements: 
On the menu bar, click Tools and then click Configure Libraries. When the Configure 
Design Libraries dialog box appears, make sure that System Libraries is selected 
(default setting). In the Available Libraries list, scroll down the list and select Circuit 
Elements. Click the Insert button , and then click OK. If Vendor Elements is not 
listed in the Configured area, you should move this across at the same time, allowing 
access to manufacturers’ component data.

c. In the Components tab of the Project Manager, confirm that the Circuit Elements 
folder has been configured and is available for use in the design.
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Place the Components in the Schematic
We start by placing the components in the schematic. 
1. Click the Components tab in the Project Manager, and then expand the Circuit Elements/

Filters folder and the Chebyshev icon.

2. Select Chebyshev Band-Pass Filter, and then right-click Place Component. 
3. Now drag the cursor into the Schematic Editor window, and note that the cursor changes into 

the filter’s schematic symbol. 
4. Move the symbol near the left side of the screen, then right-click and select Place and Finish. 
4 - 6 Discrete Time Domain



Example: A Double Down-Conversion Receiver
5. Place two additional Chebyshev Band-Pass filters so that your schematic looks like this:

Note that to make multiple copies of a component, you can use any of these shortcut tech-
niques to place multiple components:
• To make multiple copies: Drag the cursor into the Schematic Editor (same procedure as 

before), left-clicking to place as many copies as needed. As soon as you position the final 
schematic symbol, right-click and then select Place and Finish.

• To copy-and-paste: In the Schematic Editor, select a schematic symbol (one click). On 
the main menu bar, click Edit and Copy, and then click Edit and Paste. Drag the cursor to 
the Schematic Editor, position the component, and then right-click Place and Finish. 

• Alternatively, you can copy-and-paste by selecting the component and then applying the 
standard Windows shortcut keys (Ctrl +C and Ctrl +V). 
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6. In the Project Manager, expand Ideal Distributed (under Circuit Elements) and select 
Transmission Line, Physical Length:
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7. Drag the cursor into the Schematic Editor, and—using any of the techniques described 
earlier—place two copies of the transmission line, as shown. At this point your schematic 
should look like this:

8. In the Project Manager, under the System Elements icon, expand the Nonlinear RF folder.
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9. Select Amplifier, Full Listing, and then place four instances in the Schematic Editor: 
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10. Place the mixers: 
a. In the Project Manager, under the System Elements folder, expand the Nonlinear RF 

icon and select Mixer, Full Listing:

b. Now place two instances of the mixer in the Schematic Editor, as shown. 
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c. If you need additional space between unconnected sections, create a bounding box around 
a group of elements and then move them. (Click the left mouse button, drag the cursor to 
select a group of components, and then move the group.)

11. Add the voltage and power probes: 
a. In the Project Manager, under the System Elements folder, expand the Probes icon and 

select Voltage Probe (located at the bottom of the list). Insert two copies of the voltage 
probe (input and output) as shown. 

b. Select Power Probe and insert it as shown: 
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12. Add the input and output ports and define their parameters: 
a. On the Schematic Draw toolbar, click the Interface Port icon.  and place ports at the 

input and output, as shown.

b. After a port is placed, you can open the Port Definition dialog box by double-clicking the 
port symbol.
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13. Define the source (excitation) for Port1:
a. In the schematic editor, double-click the input port. The Port Definition dialog box 

appears. (Same procedure as previous step.)
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b. Make sure that the following values appear:

c. Under Source Definition, click Add, and the Source Selection dialog box appears.
d. Set power (p) to -70 dBm, and select dBm in the Unit list, if desired (variables may be 

added without specifying a unit). 
e. Specify a variable for frequency:

• Type a new variable name, FF, in the Property text box in the Frequency row.

The Add Variable dialog appears. 
• Type 3.9GHz in the Value box and verify that the Local Variable button is selected, 

then click OK. 
f. Click OK to close the Source Selection and Port Definition dialog boxes. 

Port name Port1

Port Number 1

re: 50

im: 0

Microwave Port Selected
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• Note that schematic symbol for port1 has changed into a source symbol. 
• Note that the microwave port has been flipped in the x direction.
• Also note that you can add additional sinusoidal excitations. At this point, your 

schematic should look like this:

Edit Component Properties
Define the parameters for Filter1:
1. Double-click the schematic symbol for the first filter, and the Properties dialog box appears.
2. Enter the values for N, FL, FU, RIP, QU, and RRE as shown. (If a property has units, do not 
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insert a space between the number and units, for example, 3.8GHz).

3. To display additional information about this component (for example, model notes and netlist 
syntax) click the CBPF button and the Ansoft Designer Help window opens.

4. Now enter the following values for Filter2 and Filter 3: 

Filter2 Filter3
N 5 5

FL 1.15GHz 0.25GHz

FU 1.25GHz 0.35GHz

RIP 0.2 0.2

QU 1000 1000

RRE 50 50
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5. Enter the following values for the transmission lines (leave Z and F unchanged):

Create a Variable to Define Gain
Create a local variable that will be used to define the gain for the fourth amplifier: 
1. On the System menu, click Design Properties. 

In the Properties dialog box, click the Local Variables tab and then click Add. 
The Add Property dialog box appears.

2. In the Name box, enter Gain_1.
3. In the Value box, enter 10.

4. Click OK.
For additional explanation of parameters and variables, see Chapter 1, Terms Used in Ansoft 
Designer.

Use an external file to specify compression characteristics for the second amplifier: 
1. In this example, we use an external data file, Comrec.flp, to define the compression 

characteristics for the second and fourth amplifiers. (Later, in step 27, we use this file to define 
the intermodulation table for the two mixers.) 

2. Double click the second amplifier, and the Properties dialog box appears. 

TRLK1 TRLK2 TRLK3
P 1in 240 in 1in

K 9.8 2.1 9.8

A 1.9685 0.98425 1.9685

F 3.9GHz 1.2GHz 1.2GHz
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3. In the File row, under value, click the blank button. 
4. In the Select File dialog box, select Use Path and click the browse button . to browse to 

the directory where Ansoft Designer is installed. Browse to: Examples\System\comrec.flp. 
5. Click Open, and then OK.

6. Click OK to close the Select File and Properties dialog boxes.
7. Set values for Amplifier1, Amplifier2, Amplifier3, and Amplifier4 as shown in the table 

(leave all other values unchanged): 

Amplifier1 Amplifier2 Amplifier3 Amplifier4
FILE comrec.flp comrec.flp

DEVICE MID_GAIN GAIN_2

MS11 -12 -12 -12 -15

MS12 -60 -60 -50 -50

MS21 30 Gain_1

MS22 -18 -18 -15 -15

NF 2 6 8 6

OIP3 0dBm 10dBm

P1DB 5dBm
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8. Set values for the Mixer1 and Mixer2, as shown in the table:

9. Assign a name to each of the probes: 
a. Double-click the first voltage probe, and its Properties dialog box appears. Enter Vin for 

Name and then click OK to close.
b. Double-click the second voltage probe, and its Properties dialog box appears. Enter Vout 

for Name and then click OK to close.
c. Double-click the power probe, and its Properties dialog box appears. Enter Pout for 

Name and then click OK to close. 
d. At this point, the schematic has all of the necessary parameter values assigned. 

10. Change the schematic name from System1 to SingleTone: 
a. In the Project Manager, right-click the System1 icon, select Rename, and then type Sin-

gleTone.
b. On the menu bar, click File and then click Save. When the Save dialog box opens, enter 

ComReceiver in the Name field. 

Set up the System Analyses
Two separate analyses will be set up for this project: A simple frequency-domain sweep, and a 
discrete time-domain analysis (which requires additional data in the Source Selection dialog box).

Mixer1 Mixer2
FILE comrec.flp comrec.flp

DEVICE MIX_1 MIX_2

TEMP

MS11 -10 -12

MS22 -10 -15

CONVGAINMAG -8.5 -10

NF 8 10

OIP3 20dBm

MAXO 10 10

MINF 1GHz 0.1GHz

MAXF 6GHz 1GHz

FLO 2.7GHz 0.9GHz
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Frequency Domain Example
To set up a frequency-domain analysis: 
1. On the System menu, click Add Analysis Setup.
• Alternatively, in the Project Manager, right-click the Analysis icon and then click Add 

Analysis Setup. 

The Analysis Setup dialog box appears.
2. Accept the defaults for Analysis Name and Analysis Type. Click Next.

3. In the System, Frequency Domain Analysis dialog box:
a. Make sure that Enable Group Delay Calculations and Enable Noise Calculations are 

selected. 
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b. Make sure that Perturbation (%) and Noise Bandwidth are set to 0.01 and 10MHz.

4. In the System, Frequency Domain Analysis dialog box, click Add and the Add/Edit Sweep 
dialog box appears:
a. In the Variable list, select FF.
b. Select Linear Step and enter 3.8 GHz for Start, 4 GHz for Stop, and .0025 GHz for 

Step. (Make sure that the units are set to GHz).
c. Click Add and then click OK to close the Add/Edit Sweep dialog box. 
d. Click Finish to close the System, Frequency Domain Analysis dialog box.
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Start the analysis: 
• In the Project Manager, right-click the Analysis icon and then click Analyze. 

As soon as the analysis starts, the Progress window becomes active: 
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• Check the Message Manager for status: 
In this example the message confirms a successful analysis, but if an error occurs it will be 
reported here. 

Time Domain Example (TD1)
To analyze the receiver in the discrete time domain:
1. First, you must provide additional timing information for the input source: Double-click on the 

input port, and the Port Definition dialog box appears. 
2. In the Port Definition dialog box, under Source Definition., select Sinusoidal1.
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3. Enter 1024 for Number of Samples, and enter 0.5GHz for Sampling Rate. (These additional 
parameters are required for discrete time analysis).

• Note that the total duration of the discrete-time simulation will be Number of Samples/
Sampling Rate = 2.048 µs.

• Also note that since Sampling Rate is less than the source frequency (f), this discrete time 
simulation is based on envelope analysis, so the source fundamental carrier (f) is not sam-
pled. In this case, a single sinusoid has a constant envelope proportional to the source 
power. Envelope simulation is usually a more efficient choice when we are only interested 
in examining in-band responses.

4. Click Edit. The Source Selection dialog box appears.
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5. Verify that f is set to FF, and leave p set to -70 dBm. Leave the other parameters unchanged.
6. Click OK.
To set up a time-domain analysis: 
1. On the System menu, click Add Analysis Setup. 

• Alternatively, in the Project Manager, right-click the Analysis icon and then click Add 
Analysis Setup. 

2. When the Analysis Setup dialog box appears, accept the default for Analysis Name and select 
Discrete-Time Domain Analysis as the Analysis Type, and then click Next.

The System, Discrete-Time Domain Analysis dialog box appears.
3. Select Convolution Analysis.
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4. Set Minimum Bandwidth to 2.5 MHz and Maximum Ratio to .015, as shown.

5. To set the Sweep Variables: Click Add, and the Add/Edit Sweep dialog box appears. 
6. In the Variable list, select Gain_1. 
7. Select Linear Step and enter, 10, 15, and 1 in the Start, Stop, and Step fields. Click Add.
8. Click OK and then click Finish to close the Add/Edit Sweep and System, Discrete-Time 

Domain Analysis dialog boxes.
Start the analysis: 
• In the Project Manager, right-click the TD1 icon and then click Analyze.

Note that the Start Analysis command sequentially runs all of the analysis-setups in the 
design. To run an analysis for TD1 only, right-click the TD1 icon and select Analyze TD1. 
Note that as soon as an analysis starts, the progress bar appears:
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Check the Message Manager for status: 
In this example the message confirms a successful analysis, but if an error occurs it will be reported 
here. 

Display the Results
At this point we’ve successfully run a frequency-domain analysis (FD1) and a time-domain 
analysis (TD1). Now we’ll display the results for both cases.

Display Results for the Frequency-Domain Analysis
To report the results for FD1:
1. On the System menu, click Create Report. Also note these two alternative ways to insert a 

report: 
• On the Systems Solutions toolbar, click the Create Report icon.  
• In the Project Manager window, right-click the Project icon, point to Create Report.

2. When the Create Report dialog box appears, click OK. Select Standard and Rectangular Plot.
3. In the Traces dialog, plot S21 and NF: 

a. In the Solution list, make sure that FD1 is selected (default setting).
b. In the Domain list, make sure that Sweep is selected. 
c. Add the first trace: In the Category, Quantity, and Function lists, select S Parameter, 

S21, and dB. Click Add Trace, and the data is displayed in the first row. 
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d. Add the second trace: In the Category, Quantity, and Function lists, select Noise, NF, 
and dB. 

e. Click Add Trace, and the data for the second trace is displayed in the second row, as 
shown. 

4. To plot NF on a separate Y-axis: 
a. In the trace-display area (located at the top of the Traces dialog box), move the cursor to 

rightmost column and click the area under the Y-Axis column. A list of Y-Axis labels 
appears (Y1, Y2, and so on).

b. Select Y2 for the NF so that the noise figure is plotted on a separate Y-axis to the S-
parameter.

c. Click Done and the graphs for S21 and NF will appear as shown.
d. To generate a variety of other responses, just repeat this procedure. (For additional details 

about the Traces dialog, see the first chapter of this Getting Started Guide.)
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Display Results for the Time-Domain Analysis
In this case, we will plot the spectrum variations when the gain of the fourth amplifier is swept (a 
local variable, Gain_1, was set up and assigned to in steps 18 and 21). 
To report the results for TD1:
1. On the System menu, click Create Report. Also note these two alternative ways to insert a 

report: 
• On the Systems Solutions toolbar, click the Create Report icon.  
• In the Project Manager window, right-click the Project icon, point to Create Report.

2. When the Create Report dialog box appears, click OK. Select Standard and Rectangular Plot.
3. In the Traces dialog, plot the spectrum for the output-voltage probe (Vout): 

a. In the Solution list, select TD1.
b. In the Domain list, select Spectral. 
c. Add the trace data: In the Category, Quantity, and Function lists, select Probes, 

VP(name=VP:Vout, and dB. Click Add Trace, and the data is displayed in the first row. 
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.

4. Click Done. 
5. To see how the spectral plot varies for various values of gain (for example, 10 dB or 13 dB), 

click the thumbnails on the right side of the display. Zoom in on areas of interest.
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